aleksandr.ru - блог https://aleksandr.ru/blog Последние посты блога Mon, 03 May 2021 18:24:47 +0300 ru aleksandr.ru Лампочка https://aleksandr.ru/blog/lampochka https://aleksandr.ru/blog/lampochka#comments Mon, 03 May 2021 18:24:47 +0300 https://aleksandr.ru/blog/lampochka nonadult aleksandr.ru Креатифф 3D Лампочка

Вот он бытовой профит от 3д-принтера. Дома давно пропадала лампочка Эдисона, которую хотелось куда-то применить. И вот, с появлением принтера, нарисовал и напечатал для нее подставку. Моя первая общественно-полезная модель собственной разработки.

Steampunk lamp gear


Сама модель напечатана из PLA в самом быстром режиме, но даже так ушло 6 часов. Потом грунтовка и окраска в золотой цвет. Вполне может быть напечатана любым другим пластиком с металлическим эффектом, чтоб не красить.

Далее берем обычный керамический патрон для лампочки E27, провод с выключателем и саму лампочку. Лампочки на любой вкус есть на али или в магазинах вроде леруа мерлен, цоколь и провод проще и дешевле в леруа. Краска и грунтовка в любом авто-магазине, есть даже в авто отеле в ашане.

Сборка элементарная, для прокладки провода в пластике предусмотрен канал с фиксаторами. Никаких оголенных контактов снизу, все безопасно.

Скачать модель для печати и посмотреть еще фото можно на thingiverse.

Справедливости ради, надо заметить что лампочка в форме большого шарика, ради которой все затевалось, так и осталась пропадать, поскольку оказалась слишком яркой для настольного применения. Пришлось заказывать менее яркую лампу в форме груши с желтоватым отливом, который отлично подошел к золотому цвету.

]]>
Dynamic DNS на Яндексе силами MikroTik RouterOS https://aleksandr.ru/blog/dynamic_dns_na_yandekse_silami_mikrotik_routeros https://aleksandr.ru/blog/dynamic_dns_na_yandekse_silami_mikrotik_routeros#comments Fri, 23 Apr 2021 18:06:42 +0300 https://aleksandr.ru/blog/dynamic_dns_na_yandekse_silami_mikrotik_routeros nonadult aleksandr.ru DNS Mikrotik Dynamic DNS на Яндексе силами MikroTik RouterOS

Mikrotik

Все началось с того, что мне захотелось слушать музыку в машине, но надоело писать файлы на флекшки. Варианты всяких источников из интернета были так же быстро отметены, поскольку требуют денег или добавляют платные сервисы на мобильник, запретить которые оператор не в состоянии (оно и понятно, это их доход). После очередной ругани с оператором, я забил на все приложения вида "радио бесплатно и без рекламы" и решил поднять свое радио, благо музыки на домашнем сервере хватает.

Не буду описывать как поднять Icecast и вещать в интернет mp3-шки, и пробросить порт на микротике, это все гуглится и делается без бубнов. С одним лишь замечанием, многие провайдеры, среди которых билайн, блокируют все входящие на порты меньше 1000, поэтому придется жить на четырехзначном порту.

Вишенкой на торте всей этой конструкции является заворачивание своего динамического IP в доменное имя. Существует много dDNS провайдеров, в том числе встроенные в роутеры, но раз уж у меня свой домен, то радио должно быть тоже на нем. Я использую бесплатный Яндекс DNS aka почта для домена. У этого сервиса есть АПИ, плюс обновления в ДНС проходят достаточно быстро, этого вполне достаточно для моих целей.


В домашней сети я использую роутер Mikrotik, это действительно стоящая штука для тех кто хочет не просто интернет в телефончике, а нормальную сеть дома. Да, в настройке он сложнее чем большинство роутеров, но обладает несравнимо большими возможностями. Это реально стоит того, чтоб хоть немножко начать разбираться, ну а для тех кому знакомо администрирование сетей на юникс-подобных, многое будет привычно и удобно.

За основу была взята статья Делаем dDNS-клиент для DNS Яндекса на MikrotikOS и RouterOS (MikroTik) Yandex DNS subdomain A record updater. Все можно было бы просто скопипастить, если б янедкс не обновил апи, и немного не поменял формат выдачи. Так же я разгрузил логику получения идентификатора записи по имени домена, это достаточно сделать один раз руками и сократить львиную долю скрипта. После некоторых экспериментов получился вот такой скрипт:

# To use the script, add it to the scheduler and set interval 5 minutes.
# /system script run UpdateYaDNS.rsc

# get token
# https://pddimp.yandex.ru/get_token.xml?domain_name=...
# get record id
# https://pddimp.yandex.ru/nsapi/get_domain_records.xml?token=...

:local apiToken "...";
:local recordId "...";
:local ttl "3600";
:local domain "...";
:local interfaceName "...";

:local currentInterfaceIp [ :tostr [ /ip address get [/ip address find interface=$interfaceName] address ] ];
:set currentInterfaceIp [ :pick $currentInterfaceIp 0 [ :find $currentInterfaceIp "/" ] ];
:if ([ :len $currentInterfaceIp ] = 0 ) do= {
    :log info "[Ya.DNS] No IP address is assigned to the interface '$interfaceName'.";
    :error "[Ya.DNS] No IP address is assigned to the interface '$interfaceName'.";
}

:local subdomain [ :pick $domain 0 [ :find $domain "." ] ];
:local externalIp [ /resolve $domain ];
:if ($currentInterfaceIp != $externalIp) do={
    :put "[Ya.DNS] IP $externalIp changed to $currentInterfaceIp";
} else={
    :error "[Ya.DNS] IP is not changed";
}

:local result [ /tool fetch \
    mode=https \
    url=( "https://pddimp.yandex.ru/nsapi/edit_a_record.xml?token=" . $apiToken . "&record_id=" . $recordId . "&content=" . $currentInterfaceIp . "&ttl=" . $ttl . "&subdomain=" . $subdomain ) \
    as-value output=user ];

:local data ($result->"data");
:local error [ :pick $data ([ :find $data "" ] + 7) [ :find $data "" ] ];
:put $error;
:if ($error != "ok") do={
    :log warning "[Ya.DNS] Unable to update record $recordId ($error)";
    :error "[Ya.DNS] Unable to update record $recordId ($error)";
}

:log info "[Ya.DNS] Successfuly updated A record $recordId ($currentInterfaceIp)";

Согласно комментариям в шапке скрипта идем и получаем токен по имени домена (для этого нужно быть залогиненым на яндексе), затем получаем ид записи с помощью токена. Подставляем эти данные плюс название интерфейса со внешним адресом и полное имя домена в переменные. В блоке Policy отмечаем "ftp" и "read", и добавляем скрипт на свой роутер под именем UpdateYaDNS.rsc, далее ставим его в планировщик раз в 5 минут или как вам больше нравится, не забудьте добавить "test" в Policy у записи в планировщике. Результат действий можно будет увидеть в логах.

]]>
Мощность резисторов https://aleksandr.ru/blog/moschnost_rezistorov https://aleksandr.ru/blog/moschnost_rezistorov#comments Thu, 22 Apr 2021 12:35:38 +0300 https://aleksandr.ru/blog/moschnost_rezistorov nonadult aleksandr.ru В мемориз Железо Мощность резисторов

Когда сопротивление начинает обжигать пальцы, невольно задумываешься об увеличении его номинала или мощности. Поскольку мощность на резисторах никак не обозначена, поможет эта картинка:

Таблица размер-мощность аксиальных (цилиндрических) резисторов.

Просто посмотреть на нее будет достаточно для решения большинства вопросов, а если нет, то можно почитать оригинальную статью. Для справки, с известного китайского сайта приходят резисторы размером немного меньше, чем должно быть для заявленной мощности, естественно это сказывается на тепловыделении при их использовании.

]]>
Дружим VSCode и Arduino https://aleksandr.ru/blog/druzhim_vscode_i_arduino https://aleksandr.ru/blog/druzhim_vscode_i_arduino#comments Mon, 19 Apr 2021 11:22:59 +0300 https://aleksandr.ru/blog/druzhim_vscode_i_arduino nonadult aleksandr.ru В мемориз Arduino Дружим VSCode и Arduino

Arduino + Visual Studio Code

Arduino IDE всем хороша, за исключением того, что писать код в ней просто неудобно. В поисках альтернативы настроил более-менее привычный для меня Visual Studio Code под написание кода для ардуино.


К сожалению, для работы с ардуино в VSCode не достаточно просто поставить плагин из маркета, это микрософт во всей красе! Вам так же понадобится установить cpptools и настроить его при помощи гугла и опыта других пользователей, странно что про эти настройки не пишут в документации.

Итак, ваш settings.json должен включать следующее (это все можно накликать в интерфейсе, но проще так):

Для MacOS:

    "arduino.path": "/Applications",
    "arduino.commandPath": "Contents/MacOS/Arduino",
    "C_Cpp.default.includePath": [
        "/Applications/Arduino.app/Contents/Java/hardware/**",
        "/Applications/Arduino.app/Contents/Java/libraries/**",
        "~/Documents/Arduino/libraries/**"
    ],
    "C_Cpp.intelliSenseEngine": "Tag Parser"

Для Linux:

    "C_Cpp.intelliSenseEngine": "Tag Parser",
    "C_Cpp.default.includePath": [
        "/usr/share/arduino/hardware/arduino/**",
        "/usr/share/arduino/libraries/**",
        "~/Arduino/libraries/**"
    ]

Для Windows, наверное, аналогично, но сам не пробовал.

После этого начинает работать менеджер библиотек, а из редактора уходят ошибки про несуществующие include, и начинают работать подсказки кода. Конечно, подсказки далеки от идеала, оно собирает все возможное со всех *.h файлов в includePath, не обращая внимания на те, что реально включено в вашем коде, но это уже гигантский шаг вперед по сравнению с Arduino IDE.

P.S. Удивительно, насколько среда разработки влияет на процесс написания ПО. Изначально я достаточно долго ковырял прошивку для декодера шагового двигателя в "родной" Arduino IDE, а когда дошли руки настроить Visual Studio Code для работы с ардуино, все было завершено за пару дней.

]]>
Нежелезные дороги на макете https://aleksandr.ru/blog/nezheleznie_dorogi_na_makete https://aleksandr.ru/blog/nezheleznie_dorogi_na_makete#comments Sun, 18 Apr 2021 00:31:02 +0300 https://aleksandr.ru/blog/nezheleznie_dorogi_na_makete nonadult aleksandr.ru Хобби H0 Нежелезные дороги на макете

Начнем с дорог для автомобилей, а именно, с имитации асфальтового покрытия. Для справки, ширина обычной двухполосной дороги в масштабе 1:87 составляет примерно 8 см. На обочину нужно закладывать 1-2 см. в зависимости от конкретного места. Итак, приступим...

Контуры дороги


В начале нужно наметить контур будущей дороги, который поможет укладывать шпаклевку. Большинство использует для этого двусторонний скотч толщиной 2 мм. Для себя я нашел альтернативу уплотнитель самоклеящийся для окон ПВХ 6 м 10х2 мм, бывает черный и белый, с успехом заменяет скотч и имеет только одну липкую сторону, что весьма удобно; по цене он так же выгоднее скотча.

Слой выравнивающей шпаклевки

Далее слой выравнивающей шпаклевки. В силу своих особенностей, она заполняет все неровности и дает приличную усадку, так что, после высыхания слой становится ощутимо тоньше, чем при нанесении и образует бортики вдоль уплотнителя. Сохнет этот слой примерно сутки. Так же она слишком гладкая для асфальта, поэтому...

Слой финишной шпаклевки

Поверх выравнивающей кладем слой финишной шпаклевки, которая почти не дает усадки, и после высыхания формирует почти нужную текстуру асфальта. Но есть нюанс, после нанесения разровнять ее есть всего одна попытка (следующие сильно испортят "гладь" асфальта). Поэтому, заранее подготовленным чистым шпателем шириной 10 см., проходим по набросанной с небольшим запасом шпаклевке и более не трогаем. Если результат не устроил, то приходится переделывать достаточно большой участок. Идеала добиться невозможно, поэтому можно забить на мелкие огрехи и поправить их шкуркой когда высохнет. Сохнет этот слой тоже сутки примерно.

Окраска дороги

Когда высохнет шпаклевка, отдираем формовочный утеплитель и шкурим наждачкой с зерном 40-200. Таким образом убираем огрехи и, главное, бортики вдоль дороги, там где был уплотнитель или разровнял сильнее чем хотелось. При большом желании можно зашкурить хоть всю поверхность. Полученный результат пылесосим и красим в цвет асфальта краской Tamiya XF-24. На мой взгляд и после многих экспериментов с цветами и шпаклевкой, она лучше всего подходит под цвет асфальта.

Теперь самое сложное. Поскольку моя дорога проходит под мостом у задника макета, то засадить это место травой с помощью флокатора нет возможности. Поэтому в недоступных для флокатора местах я использую травяной коврик Busch с высотой травы 5-6 мм. Заранее вырезаю нужную форму из бумаги, а потом по ней отрезаю уже от коврика.

Левая обочина с травой

Приклеиваем вырезанную из коврика траву на ПВА, куски небольшие т.к. там где можно подлезть буду флокатором, буду делать им.
Далее намазываю ПВА место для обочины между травой и асфальтом, засыпаю сверху песком, выравниваю кисточкой и пальцем. Поскольку слой песка толстый, то сверху прокапываю тем же ПВА, но разведенным с водой в соотношении 1:1 и немного средства для стекол (прямо как при отсыпке рельс балластом). Это был вариант №1.

Правая обочина

Справа сначала отсыпаю обочину песком на слой ПВА, разравниваю пальцем. Укрываю все вокруг, что окрашено акриловой краской, брызгаю песок спиртом и прокапываю разведенным клеем. Только потом приклеиваю траву. Это вариант №2.

Дорога с обочинами и травой

Результат обоих вариантов на фото, правда еще не высохший. Как ни странно, но мне более натуральным кажется слева, когда сначала клеил траву, а потом песок. 

Теперь дело за дорожной разметкой. Ее буду наносить белым лаковым маркером Edding для стекол, он оказался самым лучшим среди аналогов, которые нашел в магазине. Остальные либо не видно (плохо видно), либо разъедают акрил (и, кстати, пеноплекс тоже). Удивительным оказался двухцветный маркер "спец", точнее его белая часть, когда им рисуешь, то остается прозрачный след, который через некоторое время высыхает и становится белым. Он чуть более бледный чем Edding, но в некоторых случаях будет весьма хорош.

Незаменимым помощником в нанесении разметки в поворотах будет гибкая линейка. Ей можно придать нужную форму, которую она будет держать.

P10330-210647.jpg

А для рисования пешеходных переходов и других элементов дорожной разметки будет полезен набор трафаретов для 3D-принтера. В нем есть достаточно дорожных символов, три из которых на фото. Однако, трафареты рассчитаны на баллончик или аэрограф, поэтому от кисточки будет мало толку. Более-менее выходит спонжем (на фото), но предварительно стоит потренироваться где-то, чтоб не закрашивать по несколько раз. Густота краски в этом случае тоже имеет не последнее значение, например беля ZipMarket и Tamiya дают совершенно разный результат.

Удивительно, насколько разметка на дороге оживляет весь вид даже недостроенного макета!

Данный способ подходит для создания дорог любой сложности, ниже процесс постройки подъема к складу.

P10328-162316.jpg

Сам подъем я сделал из достаточно грубой лесенки из кусков пеноплекса, все ее недостатки скроет шпаклевка.

P10328-163859.jpg

Согласно ширине дороги приклеиваем все тот же уплотнитель, только теперь белый, кроме цвета, разницы никакой. 

P10328-170145.jpg

Из-за перепада высот, первый слой выравнивающей шпаклевки ложится с изъянами, это не страшно, будет еще второй слой финишной шпаклевки и проход наждачкой с зерном 80 для создания рельефа асфальта.

P10404-133103.jpg

После ошкуривания и окраски, с использованием уже освоенной технологии гнутых стен, получается вполне симпатичный поворот дороги.

]]>
Торт для моделиста https://aleksandr.ru/blog/tort_dlya_modelista https://aleksandr.ru/blog/tort_dlya_modelista#comments Sat, 17 Apr 2021 23:51:18 +0300 https://aleksandr.ru/blog/tort_dlya_modelista nonadult aleksandr.ru За жизнь Хобби Торт для моделиста

Совсем недавно был приятно удивлен вот такому торту-макету железной дороги

P10417-173402.jpg

Чего только не придумают кондитеры, и как приятно, когда близкие такое находят)

]]>
Привод стрелки шаговым двигателем https://aleksandr.ru/blog/privod_strelki_shagovim_dvigatelem https://aleksandr.ru/blog/privod_strelki_shagovim_dvigatelem#comments Mon, 22 Mar 2021 19:05:40 +0300 https://aleksandr.ru/blog/privod_strelki_shagovim_dvigatelem nonadult aleksandr.ru Хобби H0 Железо 3D Привод стрелки шаговым двигателем

Попробовав переключать стрелки с сервоприводом, я быстро понял, что этот вариант мне не подходит - сервопривод слишком большой и мощный, плюс он двигается по кругу, а не линейно.

Спустя продолжительное время после упражнений с сервоприводами под стрелкой, рядом со стрелкой, и т.д., приехали моторчики, потенциальные кандидаты в будущие приводы. Вот так они выглядят рядом со стрелками:

Кандидат в приводы стрелок

Моторчики эти существуют в двух вариантах: с полукольцом (на фото) и с ушком за которое можно закрепить что-то винтом.


Для проверки сделал тягу из проволоки 0.5 мм., которая прекрасно держится за выступ с полукольцом, собрал схему с ардуино, стабилизатором питания AMS1117 и драйвером MX1508, взял элементарный скетч для шагового двигателя, настроил движение на 450 шагов + ресет на 500, и результат оказался очень хорошим:

Видео на youtube

У меня стрелки Peco с достаточно мощной пружиной, которая обеспечивает нужное прижимание остряка, демонтировать пружину не требуется. Мотор запитан от стабилизатора 3.3 В, чтоб преодолевать сопротивление пружины, а при встрече с препятствием пропускать шаги не повреждая ничего вокруг. Тяга из проволоки сама тоже немного пружинит, а так же пружинит в местах крепления к стрелке и редуктору. Плюс есть небольшой люфт в крепеже тяги к стрелке и редуктору, что дополнительно защищает стрелку от повреждения при переключении, т.е. финальные доли миллиметра остряк проходит под действием родной пружины в стрелке, а тяга его догоняет.

Подбирать ход тяги для каждого экземпляра не требуется, мотор делает всегда одинаковое количество шагов, один раз подобранное для оптимального переключения стрелки, На случай непредвиденной потери питания предусмотрен "ресет", который сдвигает редуктор в крайнее положение без риска повреждения стрелки т.к. это положение ограничено корпусом редуктора. В целом конструкция получилась очень удачной.

Схема в стиле кишки наружу

На фото выше первая сборка прототипа декодера для управления шаговым двигателем привода стрелки. Схема управления шаговым двигателем крайне простая. Схема для чтения DCC-пактов сложнее, но тоже ничего сверхъестественного. Схемы и программы для ардуино легко гуглятся, а сложности и вопросы решаются на форумах. Ноу-хау только в том, чтоб совместить все в одном и научить правильно работать.

Изготовление корпуса привода

Изначально планировался всего один вариант исполнения привода, но на практике их получилось несколько для разных вариантов размещения. Для проектирования 3D-моделей приводов я освоил FreeCAD, который не лишен недостатков, но для моих целей оказался гораздо удобнее браузерного Tinkercad. Разработка каждого варианта заняла много времени как на проектирование, так и на тестирование результата, и породила много пластикового брака. Описывать тонкости процесса нет смысла, в целом все сводилось к измерениям, проектированию, печати, проверке; и так много раз. В результате появилось несколько жизнеспособных вариантов приводов. Так же в процессе разработки проволочная тяга была заменена пластиковой, которую легче воспроизвести и выглядит она лучше, а сам редуктор на вариант с ушком вместо полукольца для возможности использования винтов в креплении тяги.

Накладной привод

Размещается непосредственно рядом со стрелкой на поверхности макета. Максимально нагляден и удобен в обслуживании, но занимает достаточно много места.

P10227-190514.jpg

Обычная крышка Компактная крышка

GP35 с выступающими частями проходит привод со стандартной крышкой

Разместить такой между путями, расходящимися из стрелки не получится. Если расположить такой привод сразу после спуска, то некоторые локомотивы и вагоны с сильно выступающими частями могут его цеплять при переходе со спуска на ровную стрелку. Для снижения этих рисков у привода предусмотрено несколько вариантов крышки: обычная, компактная и сверх-компактная.

Накладной привод с датчиком положения

Поскольку одна из стрелок у меня расположена в туннеле, то отсутствует возможность визуального контроля ее состояния и возможных проблем с переключением. Для того, чтоб быть уверенным в ее состоянии, в накладной привод был добавлен оптический датчик и модернизирована тяга.

P10503-121443.jpg P10503-121421.jpg P10503-121421.jpg P10503-121421.jpg

На тяге "гребенка" с шагом 1 мм, на перевод стрелки приходится 4 срабатывания датчика, это вполне достаточно для контроля положения. Красный пластик "прозрачный" для датчика, поэтому окрашен в черный цвет.

Туннельный привод

Не всегда можно расположить накладной привод в нужном месте. Например, когда две стрелки установлены подряд, не получится разместить привод между путей выходящих из соседней стрелки. Для таких ситуаций была сделана компоновка, в которой мотор вынесен от стрелки на некоторое расстояние, а усилие передается тягой, идущей в туннеле в основании макета. Такая конструкция требует бОльших усилий для перевода стрелки, поэтому расстояние, на которое можно вынести мотор, ограничено.

P10321-004411.jpg P10321-004417.jpg P10321-004428.jpg

Кассетный привод

Эта компоновка была разработана для минимизации видимой части привода. Редуктор мотора расположен перпендикулярно плоскости стрелки, на съемной кассете. Большая часть расположена ниже уровня макета, видимой остается лишь тяга и плоскость основания.

Видео на youtube

P10320-010556.jpg P10320-010610.jpg P10320-010727.jpg P10320-010837.jpg P10320-010901.jpg

Подмакетный привод

Эта конструкция является развитием кассетного привода. Подстрелочное расположение механизма давно снискало народную любовь, поскольку имеет минимум видимых частей. Для использования такого привода требуется относительно тонкий подмакетник и возможность свободного доступа снизу.

P10325-234152.jpg P10325-234247.jpg

Очевидным недостатком такой компоновки является сложность обслуживания, невозможность размещения в толстых подмакетниках (например из ЭППС как у меня) и невозможность размещения в районе ребер жесткости, которые заблокируют возможность доступа к приводу снизу.

Arduino DCC step motor shield

Мне требовалось устройство, на котором можно было бы отладить схему и ПО декодера, а так же использовать для перевода приводов, пока не готовы печатные платы. Использовать сборку в стиле "кишки наружу" на макетной плате (фото выше) было крайне неудобно, поэтому был сделан шилд для ардуино уно.

Arduino DCC step motor shield

Шилд разделен на 2 платы: приемник DCC-сигнала и плата управления двигателем. На приемнике предусмотрена кнопка ручного управления, а на плате управления двигателем предусмотрен переключатель выбора питания драйвера от стабилизатора 3.3В или от 5В.

Декодер для шагового двигателя

Декодер для одного привода

В качестве промышленной реализации было решено использовать ардуино про-мини за ее малый размер. Количество её ножек вполне позволяет управлять двумя драйверами моторов одновременно. Исходя из этого будет два вида декодеров: для одного привода и двух сразу. Одиночные будут размещаться там, где одинокие стрелки вдали от других, а двойные, наоборот, найдут применение где сосредоточено много стрелок.

Декодер может быть использован не только для перевода стрелок, но и везде, где можно использовать шаговый мотор. У декодера предусмотрены гибкие настройки, позволяющие адаптировать функционал под любые цели.

На основе разработанной схемы я создал печатные платы для двух видов декодеров в EasyEDA. Платы и нужные комплектующие были заказаны на известных китайских сайтах.

Платы для декодера

Для сборки декодера требуются минимальные навыки владения паяльником.Для включения режима программирования (записи CV) предусмотрен отдельный переключатель, это позволяет программировать нужный декодер не снимая с макета.

Программное обеспечение декодера (прошивка) создана на основе открытых библиотек для ардуино и, конечно же, моего "ноу-хау", чтоб все слаженно работало вместе.

Подробное описание разработанного декодера и его настроек можно посмотреть здесь.

Данные декодеры я планирую продавать в виде КИТов для сборки вместе с приводом стрелки. Если вы заинтересованы в приобретении, пишите!

Стоимость

Для сборки экспериментального накладного привода понадобилось купить:

  • разные модели моторов, драйверы и стабилизаторы питания, примерно на 500 руб.
  • ардуино, макетная плата и всякая мелочь для нее, еще около 1000 руб.

Комплект из 10 моторов для приводов 1000 руб.

Всякие электронные компоненты для создания прототипа шилда для ардуино еще примерно 1000 руб.

Комплект 10 драйверов и разной электроники для плат 1000 руб.

Комплект из 10 ардуино про-мини 3000 руб.

3D принтер и пластик 17000 руб. (конечно он нужен не только для макета, но тем не менее)

Комплект из 10 плат для декодеров 1000 руб. (меньше 10 не заказать)

Комплект из 10 плат для двойных декодеров ? руб.

]]>
Piko 57595 Herkules ER20-009 MRCE dispolok https://aleksandr.ru/blog/piko_57595_herkules_er20_009_mrce_dispolok https://aleksandr.ru/blog/piko_57595_herkules_er20_009_mrce_dispolok#comments Mon, 15 Mar 2021 01:25:51 +0300 https://aleksandr.ru/blog/piko_57595_herkules_er20_009_mrce_dispolok nonadult aleksandr.ru Хобби H0 Обзор Piko 57595 Herkules ER20-009 MRCE dispolok

P10313-170237.jpg

Я крайне редко пишу обзоры, а уж обзор модели так вообще в первый раз. Итак, я стал счастливым обладателем относительно новой модели локомотива серии Hobby от Piko. Модель была приобретена исключительно от того, что просто нравится, и не важно, что локомотив не вписывается в эпоху и тематику моего макета, зато он черный и очень элегантный.


Внешность достаточно аскетична, тут нет множества мелких деталей, как например, у серии Expert, но это делает внешний вид строгим и стильным. Такое не очень уместно говорить о модели, т.к. ее первая задача - быть максимально похожий на оригинал, но этому локомотиву, я считаю, вполне уместно быть стильным. Да, и тут не то что бы совсем нет мелких деталей, они есть и их ровно столько, чтоб модель выглядела хорошо, но не пестрила мелочевкой.

Аскетичность так же касается и функций модели, тут нет ни разноцветия ходовых огней, ни звука, ни даже цифрового декодера. Для меня это плюс, поскольку не приходится переплачивать за то, что не нужно, например мне совершенно не нужен звук в модели.

Вместо кучи фотографий распаковки, которых навалов в подобных обзорах, я предлагаю начать сразу с интересного - с установки декодера.

P10313-164735.jpg

Сначала снимаем пластиковую крышку с серийным номером снизу, она держится на защелках со стороны кабин локомотива, легко снимается руками. Затем отворачиваем единственный крестообразный винт и снимаем корпус просто потянув вверх.

P10313-165004.jpg

Внутри расположен солидный груз, сверху которого вся необходимая электроника. Как и во всех современных локомотивах, здесь имеется заглушка (уже снята на фото выше), которая делает локомотив аналоговым, а заменив ее на декодер, он становится цифровым. Заглушка установлена в стандартный 8-пиновый разъем, она легко поддевается и вынимается вверх. Так же в корпусе модели предусмотрено просторное место для установки динамика, для тех, кто хочет модель со звуком.

P10313-165955.jpg

Размещение декодера не составляет проблем, никаких крепежей не требуется, важно только правильно вставить разъем и уложить провода так, чтоб ничему не мешали. На плате локомотива отсутствует маркировка разъема, поэтому декодер вставляем наугад (на фото вставлен правильно). При неправильной установке, модель будет ехать, но не будет света.

P10313-170248.jpg

Свет фар реализован лампочкой, а не светодиодами, это добавляет живости модели, хотя это может показаться и не современным, но мне это понравилось. Свет горит только по ходу движения модели, да аскетично, но не вижу смысла подсвечивать прицепленные вагоны, на которых обычно нет никакого освещения.

P10313-170344.jpg

В завершении пара фотографий, чтоб оценить деталировку модели. На фото выше вверху видно решетку, под которой как раз место для динамика.

P10313-170354.jpg

Среди прочего мне весьма приглянулись колеса с точками по кругу, как у полноразмерного прототипа, они выглядят просто шикарно и очень притягательно для глаз. Именно они, возможно, сподвигли меня к покупке) 

P.S. в отличие от BR-120, здесь номера кабин подписаны, поэтому вопроса "где перед" не возникает.

]]>
Как я попытался завести канал в Дзен https://aleksandr.ru/blog/kak_ya_popitalsya_zavesti_kanal_v_dzen https://aleksandr.ru/blog/kak_ya_popitalsya_zavesti_kanal_v_dzen#comments Fri, 05 Mar 2021 17:23:42 +0300 https://aleksandr.ru/blog/kak_ya_popitalsya_zavesti_kanal_v_dzen nonadult aleksandr.ru За жизнь Как я попытался завести канал в Дзен

На радостях от собственного канала в телегармм, я решил расширить зону своего влияния на глобальную сеть при помощи яндекс дзен. На старте все выглядит весьма просто и привлекательно. Согласно документации дзена нужно всего-то завести канал, прописать в его описании сайт, поставить на сайт метрику, подтвердить сайт в яндекс вебмастере, прописать на нем ссылку на канал в дзене, и после этого можно будет отдать свою RSS-ленту в качестве источника публикаций на канале.

При всей длинности пути, это не сложно, и делается, если запастись терпением. Самым трудоемким было приведение RSS-ленты к их формату, который, кстати, не является валидным c точки зрения валидатора RSS, на который ссылается их же документация. Единственное, что немного выбивалось из общей стройной концепции, так это то, что подключение RSS-ленты делается почему-то через заявку в поддержку дзена. Тем не менее, весь путь был пройден и заветное сообщение со ссылкой на мою ленту отправлено.


Каково же было мое удивление и разочарование, когда мне вежливые ребята с той стороны объяснили, что для того, чтоб привязать RSS, канал должен набрать нужное количество кило-просмотров за нано-период! Именно канал, а не сайт (зачем, спрашивается я на сайт метрику ставил), и цифры этих кило-просмотров такие, что при моей посещаемости сайта их явно не светит, что уж говорить о новом пустом канале. И самое главное, как, как я должен наполнять свой канал информацией, чтоб привязать RSS, если вся эта информация как раз поступает из RSS?! Копипастить со своего сайта? Копипастить в 21-м веке, когда из каждого сервиса свисает по несколько апи на любой вкус?!

Буря эпического разочарования в том, как устроен дзен, со временем сменилась попыткой понять их необходимость держать авторов каналов в своем интерфейсе, ну чтоб показывать рекламу, наверное, формировать социальный профиль, завлекать в другие сервисы и т.д. И вот, я честно пошел в веб интерфейс редактора в дзене и скопипастил туда целый пост с картинками, заменил видосики ссылками, добавил ссылку на оригинал, в общем, подготовил под формат дзена.

Вишенкой на торте стало нажатие кнопки "опубликовать". Весьма аскетичный и кривовато собранный диалог известил меня, что теперь я должен ввести свой телефон и подтвердить его! Зачем!? Я ведь и так сижу под яндексовской учеткой, и про меня им известно больше чем надо! И, кстати, телефон - это персональные данные, согласия на обработку которых я нигде не давал. И почему нельзя было потребовать с меня телефон сразу,  когда я только создавал канал? Наверное, расчет на то, что зайдя так далеко, большинство дрогнет и сольет номер телефона. Омерзительный подход!

На этой ноте я проклял того, кто придумал так обходится с авторами дзена всеми теплыми словами, что смог придумать, и пошел писать этот пост. Искренне надеюсь, что когда-то яндекс одумается и сделает дзен для авторов контента таким же удобным, как и для читателей.

]]>
У меня теперь Anet ET4 Pro https://aleksandr.ru/blog/u_menya_teper_anet_et4_pro https://aleksandr.ru/blog/u_menya_teper_anet_et4_pro#comments Sat, 27 Feb 2021 11:25:24 +0300 https://aleksandr.ru/blog/u_menya_teper_anet_et4_pro nonadult aleksandr.ru Железо 3D У меня теперь Anet ET4 Pro

Anet ET4 Pro

3D-принтер Anet ET4 Pro уже хорошо известен и про него много написано, но действительно полезного в рунете написано мало. Это мой первый 3D-принтер, поэтому писать буду с точки зрения новичка.

Все началось с выбора принтера под свои потребности. Мне нужен принтер для домашних поделок небольшого размера в режиме хобби.


Я быстро отказался от рассмотрения фотополимерных принтеров т.к. жидкая ядовитая смола с явно невкусным запахом для дома не подходит, плюс необходимость промывки напечатанного и дополнительного отверждения под ультрафиолетом после печати, сильно усложняют весь процесс.

Выбор из FDM принтеров быстро сузился до известных производителей и покупки их продукции на али. Решающим стало наличие подогрева стола и тихие драйверы TMC2208, поскольку принтеру предстояло работать дома в жилой комнате. Забегая веред скажу, что на смотря на тихие драйверы поспать в квартире с работающим принтером все равно не получится и у Anet ET4 Pro тихие только 2 из 3 драйверов, ось Z перемещается более шумно.

Принтер вместе с катушкой пластика был заказан в официальном магазине на али в канун китайского нового года, но не смотря на это, все приехало за несколько дней. Тут тоже не обошлось без ложки дегтя, сначала пришел курьер и вручил заказ в виде катушки пластика, ни про какой принтер он знать не знал. При этом на али трек номер в заказе был именно от катушки, поэтому заказ успешно стал выполненным. Транспортная компания, из которой приходил курьер, подтвердила что им дали только пластик, а китайский продавец, естественно, ничего не отвечал из-за их нового года. Пришлось понервничать и даже открыть спор. Но на следующий день приехал другой курьер из другой транспортной компании, который привез коробку с принтером, все закончилось хорошо.

Обзор того что приехало в коробке и что с этим делать можно почитать тут. Обзор вполне хороший, за исключением описания калибровки, которе завело меня в несколько дней потерянного времени, поэтому я решил написать "как надо".

Калибровка Anet ET4 Pro

Возможно мне повезло, но в отличие от автора обзора выше, принтер после сборки по инструкции не требовал никаких механических вмешательств, кроме регулировки стола. Даже натяжитель ремня головки и датчик приближения не требовали корректировки, но пойдя в неправильном направлении пришлось пройти через все настройки.

Вот замечательный ролик на английском про то, как правильно и быстро откалибровать принтер:

Видео на youtube

Основные моменты в процессе калибровки:

1. Убедитесь что головка и стол двигаются рукой в горизонтальной плоскости с небольшим усилием, но равномерно без рывков, и при этом не болтаются. Если нет, то нужно покрутить натяжители.

2. Если это ваш первый принтер и на столе установлено стекло, смело снимайте его и наклеивайте на его место стол-наклейку из комплекта. Это убережет стекло от ударов головки при неправильной настройке и на этой наклейке вполне можно печатать калибровочные модели. Однако, надо быть готовым к тому, что когда снимите наклейку со стола, от нее могут остаться липкие следы, удалять которые придется при помощи ацетона и такой-то матери.

3. Перед включением принтера можно выставить стол "по бумажке". Для этого руками передвигаем стол и головку так, чтоб экструдер смотрел в центр регулировочного винта. Высоту головки меняем крутя руками привод оси Z так, чтоб лист бумаги с небольшим трением проходил между головкой и столом. Тут не нужна особая точность, важно лишь выставить высоту головки один раз на самом высоком углу стола и подогнать под нее остальные.

4. Все настройки далее нужно производить при рабочей температуре экструдера и стола. Особенно важно прогреть стол тк он железный и сильно подвержен температурным изменениям. Для этого в меню "Prepare -> Pre heat" выставляем температуры, обычно это 200 градусов экструдер и 60 градусов стол.

5. Проверяем работу датчика приближения головки к столу. Для этого в меню "Setting" отправляем головку в домашнее положение и двигая ее по оси Z понимаем когда срабатывает датчик. На картинке из инструкции нарисовано положение головки такое, что между столом и экструдером 0.2 мм (как раз лист бумаги), и от стола до датчика 2-3 мм, при этом в тексте написано, что датчик должен срабатывать за 2-3 мм до стола. Это можно понимать двусмысленно, я для себя решил что датчик должен срабатывать когда экструдер (а не датчик) находится в 2-3 мм от стола. Это убережет стол от тычков головки (у нее все же есть инерция при первичном позиционировании в домашнюю позицию). Так же это позволит избежать в домашней позиции точки пластика перед началом печати. Чтоб это сделать в меню "Setting" отправляем головку домой и двигаем по Z так чтоб она плотно прижимала лист бумаги. Затем из этого положения поднимаем на 2 мм. Теперь крутим винт датчика так, чтоб погасла лампочка и очень аккуратно обратно, чтоб она только загорелась. Датчик настроен, далее это положение будет компенсировано в меню "Prepare -> Level".

6. Теперь в меню "Prepare -> Level" нажимаем ОК чтоб головка переместилась в нужное положение и выставляем ее высоту так, чтоб лист бумаги проходил под ней с усилием (можно тянуть но не толкать). Важно после каждой корректировки высоты головки нажимать ОК, поскольку то, что вы выставили "по месту" и то, куда приедет головка после ОК будет отличаться. Еще раз ОК и переходим к ручной калибровке, для этого дважды жмем "Manual". Регулировку нужно произвести в каждом углу в последовательности 1-3-2-4. Нажимаем кнопку соответствующего угла и регулируем стол так, чтоб лист бумаги с трудом проходил между столом и экструдером. Теперь дважды жмем "Auto" и дожидаемся завершения автоматической калибровки. Смотрим на цифры (кстати они расположены зеркально столу, следите за тем какие меняются в процессе, чтоб понять к какому углу они относятся), и если они больше +/- 0.1, то нужно корректировать положение стола (либо прямо здесь либо опять через "Manual"). После этого желательно проверить установку высоты через кнопку ОК и лист бумаги, скорректировать если нужно.

Калибровка завершена и можно переходить к печати. Со временем произведенные настройки "плывут", поэтому процесс ручной и автоматической установки в "Prepare -> Level" иногда приходится повторять, когда это потребуется вы сразу заметите.

Подготовка к печати

К сожалению, нельзя просто включить принтер и нажать на печать, модель в таком случае скорее всего будет испорчена. Чтоб получить качественный результат после включения принтера нужно:

1. Прогреть стол и экструдер через меню "Prepare -> Pre heat" до температуры с которой будете печатать, обычно это 200 градусов экструдер и 60 градусов стол для печати PLA. Поскольку стол достаточно массивный то требуется время для равномерного его прогрева, для этого после достижения нужной температуры дать ему постоять в таком положении минут 5.

2. "Слить" 1-2 см филамента в меню "Prepare -> Ch fila -> Load". Эти сантиметры, которые были повторно нагреты, обычно плохо прилипают к столу и все портят. Возможно это зависит от пластика, но тот что приехал с принтером от Anet этому подвержен.

3. Протереть стол сухой чистой салфеткой, а лучше смоченной в спирте (50% раствор водки тоже подходит). Это обеспечит качественное прилипание пластика к столу, как минимум на столе-наклейке это работает, никакого клея или прочих ухищрений не требуется.

После этих простых действий отпечатки выходят качественные и с первого раза. Надеюсь мой опыт будет вам полезен.

P.S.

Полезные калибровочные модели для печати можно найти тут.

]]>